Les Essentiels
Compléter un nombre avec des 0 !

Vous travaillez avec des codes ou des identifiants et vous souhaitez faire en sorte qu’ils aient tous le même nombre de caractères ?

Plusieurs méthodes

Il existe plusieurs combinaisons de formules Excel permettant d’homogénéiser le nombre de caractères d’une plage de cellule. Pour plus de simplicité, nous utiliserons un exemple qui consiste à compléter un nombre avec des 0.

Comme dans l’exemple ci-dessous, le premier reflexe serait probablement d’utiliser la combinaison entre la formule SI et la formule NBCAR qui permet de connaître le nombre de caractères contenus dans une plage de cellule.

=SI(NBCAR(A1)=1; »0000″&A1;SI(NBCAR(A1)=2; »000″&A1;etc…)

Il est cependant possible d’utiliser d’autres méthodes moins compliquées pour obtenir le même résultat.

Fonction CONCATENER()

Cette méthode, si vous ne la connaissez pas, va vous paraître évidente et simple.

Le principe est d’utiliser la formule CONCATENER() et DROITE() pour compléter un nombre avec des 0.

=DROITE(CONCATENER(« 00000 »;A1);5)

La formule CONCATENER() ajoute 5 zéros devant le valeur de la cellule A1 et DROITE() ne renvoie que les 5 caractères en partant de la fin.

Attention

L’inconvénient de cette technique est qu’elle va ajouter des 0 même lorsque la cellule contenant la valeur à compléter est vide.

Fonction REPT()

La formule REPT() permet de répéter un texte (ou le contenu d’une cellule) un certain nombre de fois. La syntaxe est la suivante : REPT(texte;Nb fois)

La encore, il est nécessaire d’utiliser la formule NBCAR() pour identifier le nombre de caractères à ajouter. La formule REPT() va ajouter autant de 0 que nécessaire pour arriver au nombre de caractères cible (5 dans notre exemple).

Deux possibilités

Il est possible d’utiliser cette formule de 2 manières différentes :

  • =REPT(0;5-NBCAR(A1))&A1
  • =CONCATENER(REPT(0;5-NBCAR(A1));A1)

Quelques informations complémentaires

Pour utiliser la fonction REPT() efficacement, il est important de connaître les détails ci-dessous :

  • La formule renvoie une valeur texte même si le résultat est constitué uniquement de chiffres.
  • Si le nombre de fois est égal à zéro = texte vide.
  • Le nombre de fois doit impérativement être un chiffre entier et posifif.
  • Le résultat ne peut pas être de plus de 32 767.

Les formats personnalisés d’Excel

Cette technique, à la différence des 3 précédentes, permet de mettre les zéros devant un ou plusieurs chiffres tout en conservant la possibilité de faire des calculs.

Pour utiliser le format personnalisé d’Excel il suffit de suivre les étapes ci-dessous :

  1. Sélectionnez la ou les cellules.
  2. Faire clique droit puis format de cellule.
  3. Allez dans la catégorie « personnalisé ».
  4. Dans la case type indiquer autant de 0 que vous souhaitez.
  5. Puis validez.

Découvrez tous nos Essentiels

Notez nous !
[Moyenne : 4.8]
2020-05-21T18:30:24+00:00