Jumocorp : investir progressivement en bourse avec la méthode DCA

Les Essentiels
Utiliser la nouvelle fonction Excel RECHERCHEX (XLOOKUP) !

Microsoft Excel a enfin développé une fonction de recherche plus flexible que la RECHERCHEV ou la RECHERCHEH.

Une nouvelle formule Excel pour plus de simplicité : RECHERCHEX

De son nom XLOOKUP en anglais, la fonction RECHERCHEX vient compléter voire remplacer les fonctions de recherches traditionnelles comme la RECHERCHEV, la RECHERCHEH, ou INDEX EQUIV.

Cette nouvelle formule RECHERCHEX se veut plus flexible que les autres formules. En effet celle-ci est moins limitée et a moins de contraintes de recherche.

À noter que cette nouvelle formule est disponible uniquement sur Excel 365.



RECHERCHEX (XLOOKUP) VS RECHERCHEV

Comme la RECHERCHEV, la fonction RECHERCHEX permet de rechercher une valeur dans un tableau et de retourner une valeur correspondante. Ainsi les deux formules permettent de chercher des valeurs dans un tableau Excel.

La grande différence réside dans le fonctionnement de la RECHERCHEX. En effet, la RECHERCHEV ne peut rechercher une valeur qu’à partir de la première colonne d’un tableau : XLOOKUP ne se base pas forcément sur la première colonne et peut chercher à droite comme à gauche d’un tableau (comme de haut en bas). En somme, elle permet de faire la même chose que la combinaison d’Index et Equiv sans pour autant devoir combiner deux formules.



La syntaxe de la fonction Excel RECHERCHEX

Cette nouvelle formule Excel utilise plusieurs arguments :

=RECHERCHEX(valeur_cherchée, tableau_recherche, tableau_renvoyé, [si_non_trouvé], [mode_correspondance])

  1. valeur_cherchée : il s’agit simplement de la valeur cherchée et donc celle sur laquelle la formule va baser sa recherche,
  2. tableau_recherche : cet argument permet d’indiquer la plage de cellules dans laquelle est contenue la valeur recherchée. à la différence de la RECHERCHEV, il n’est pas nécessaire de sélectionner l’ensemble du tableau,
  3. tableau_renvoyé : ici il faut renseigner la plage de cellules dans laquelle est contenue la valeur à retourner. Contrairement aux recherches V et H, cette formule n’utilise pas un numéro mais bien la plage de cellules exacte,
  4. si_non_trouvé : facultatif, cet argument permet de renseigner une valeur par défaut si la formule ne trouve pas la valeur recherchée,
  5. mode_correspondance : pour choisir si la formule doit effectuer une recherche exacte (renseigner 0, retourner l’élément le plus proche et le plus petit mettre -1, retourner l’élément le plus proche et le plus grand mettre 1),

Exemple

Recherche de droite à gauche

=RECHERCHEX(C2;D2:D150;A2:A150)

Dans cet exemple, nous recherchons la valeur C2 dans la colonne D et nous voulons avoir la valeur correspondante dans la colonne A.

Recherche de gauche à droite

=RECHERCHEX(C2;A2:A150;R2:R150)

Dans cet exemple, nous recherchons la valeur C2 dans la colonne A et nous voulons avoir la valeur correspondante dans la colonne R (exactement comme une RECHERCHEV classique).

Ressortir plusieurs valeurs avec une recherche

La formule XLOOKUP offre aussi la possibilité de retourner plusieurs valeurs correspondantes à une valeur cherchée :

=RECHERCHEX(C2;R5:R150;B5:F150)

Ici la formule va chercher la valeur C2 dans la colonne R et retourner l’ensemble des valeurs correspondantes des colonnes de B à F.



En vidéo

Microsoft a créé une vidéo explicative que vous pouvez retrouver ci-dessous :



Découvrez tous nos Essentiels

Notez nous !
[Moyenne : 5]

Jumocorp : investir progressivement en bourse avec la méthode DCA
2022-01-26T18:32:51+00:00
Aller en haut